Increased rate-limit errors on API V2 endpoints

Incident Report for RevenueCat

Resolved

The incident has been resolved.
Posted Apr 22, 2026 - 19:42 UTC

Monitoring

A fix has been implemented and rate-limit errors are back to baseline. We will continue to monitor.
Posted Apr 22, 2026 - 19:24 UTC

Identified

At 18:27 UTC we noticed an increase in rate-limit errors from our v2 API endpoints for some developers since ~14:00 UTC.

We have identified the issue and are implementing a fix.
Posted Apr 22, 2026 - 19:09 UTC
This incident affected: API Uptime.