Charts not loading

Incident Report for RevenueCat

Resolved

This incident has been resolved.
Posted Sep 10, 2025 - 09:42 UTC

Monitoring

Our data infrastructure provider seems to have recovered. Charts are loading successfully again. We'll keep monitoring.
Posted Sep 10, 2025 - 09:21 UTC

Investigating

We are seeing an increased latency from our data infrastructure provider that is causing our Charts to time out while trying to load. We are investigating and trying to mitigate.
Posted Sep 10, 2025 - 09:19 UTC
This incident affected: Dashboard (Charts).